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History of Windows

Windows is the operating system sold by the Seattle-based company Microsoft. Microsoft, originally christened "Traf-O-Data" in 1972, was renamed "Micro-soft" in November 1975, then "Microsoft" on November 26, 1976. 

Microsoft entered the marketplace in August 1981 by releasing version 1.0 of the operating system Microsoft DOS (MS-DOS), a 16-bit command-line operating system 

The first version of Microsoft Windows (Microsoft Windows 1.0) came out in November 1985. It had a graphical user interface, inspired by the user interface of the Apple computers of the time. Windows 1.0 was not succesful with the public, and Microsoft Windows 2.0, launched December 9, 1987, did not do much better. 

It was on May 22, 1990 that Microsoft Windows became a success, with Windows 3.0, then Windows 3.1 in 1992, and finally Microsoft Windows for Workgroups, later renamed Windows 3.11, which included network capabilities. Windows 3.1 cannot be considered an entirely separate operating system because it was only a graphical user interface running on top of MS-DOS. 

On August 24, 1995, Microsoft launched the operating system Microsoft Windows 95. Windows 95 signified Microsoft's willingness to transfer some of MS-DOS's capabilities into Windows, but this new version was based more heavily on 16-bit DOS and retained the limitations of the FAT16 file system, so that it was not possible to use long file names. 

After minor revisions of Microsoft Windows 95, named Windows 95A OSR1, Windows 95B OSR2, Windows 95B OSR2.1 and Windows 95C OSR2.5, Microsoft released the next version of Windows on June 25, 1998: Windows 98. Windows 98 natively supported features other than those of MS-DOS but was still based upon it. What's more, Windows 98 suffered from poor memory handling when multiple applications were running, which could cause system malfunctions. A second edition of Windows 98 came out on February 17, 2000; it was named Windows 98 SE (for "Second Edition"). 

On September 14, 2000, Microsoft released Windows Me (for Millennium Edition), also called Windows Millennium. Windows Millennium was based largely on Windows 98 (and therefore on MS-DOS), but added additional multimedia and software capabilities. Furthermore, Windows Millennium included a system-restore mechanism for returning to a previous state in the event of a crash. 

Concurrent with these releases, Microsoft had been selling (since 1992) an entirely 32-bit operating system (which therefore was not based on MS-DOS) for professional use, at a time when business primarily used mainframes. It was Windows NT (for Windows "New Technology"). Windows NT was not a new version of Windows 95 or an improvement on it, but an entirely different operating system 

On May 24, 1993, the first version of Windows NT was released. It was called Windows NT 3.1, and was followed by Windows NT 3.5 in September 1994 and Windows 3.51 in June 1995. With Windows NT 4.0, launched for sale on August 24, 1996, Windows NT finally became a true success. 

In July 1998, Microsoft released Windows NT 4.0 TSE (Terminal Server Emulation), the first Windows system that allowed terminals to be plugged into a server, i.e. use thin clients to open a session on the server. 

On February 17, 2000, the next version of NT 4.0 was renamed Windows 2000 (instead of Windows NT 5.0) in order to highlight the unification of "NT" with the "Windows 9x" systems. Windows 2000 is an entirely 32-bit system with caracteristics of Windows NT, as well as an improved task manager and full compatibility with USB and FireWire peripherals. 

Then, on October 25, 2001, Windows XP arrived on the scene. This was a merger of the preceding operating systems. 

Finally, on April 24, 2003, a server operating system was released by Microsoft: Windows Server 2003.
Desktop
The on-screen work area on which windows, icons, menus, and dialog boxes appear
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Elements of Desktop

1.icon

2.folder

3.taskbar

4.Wallpaper
1.icon

A small image displayed on the screen to represent an object that can be manipulated by the user. Icons serve as visual mnemonics and allow the user to control certain computer actions without having to remember commands or type them at the keyboard.

2. Folder

A container for programs and files in graphical user interfaces, symbolized on the screen by a graphical image (icon) of a file folder. A folder is a means of organizing programs and documents on a disk and can hold both files and additional folders

3. Taskbar

The bar that contains the Start button and appears by default at the bottom of the desktop. You can click the taskbar buttons to switch between programs. You can also hide the taskbar, move it to the sides or top of the desktop, and customize it in other ways.

4.Wallpaper  
The screen background image used on a graphical user interface such as Windows. Any pattern or picture that can be stored as a bitmap (.bmp) file can be set as a screen background.

You can use files with these file extensions: .bmp, .gif, .jpg, .dib, .png, .htm.

1.icon

A small image displayed on the screen to represent an object that can be manipulated by the user. Icons serve as visual mnemonics and allow the user to control certain computer actions without having to remember commands or type them at the keyboard.

there are four basic real Icons 
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My document, Recycle Bin, Internet Explorer

My document

Any self-contained piece of work created with an application program and, if saved on disk, given a unique file name by which it can be retrieved.
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Recycle Bin

The place in which Windows stores deleted files. You can retrieve files you deleted in error, or you can empty the Recycle Bin to create more disk space.
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Internet Explorer

With Internet Explorer and an Internet connection, you can search for and view information on the World Wide Web. You can type the address of the Web page you want to visit into the address bar, or click an address from your list of Favorites. Internet Explorer also lets you search the Internet for people, businesses, and information about subjects that interest you.
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2.folder

A container for programs and files in graphical user interfaces, symbolized on the screen by a graphical image (icon) of a file folder. A folder is a means of organizing programs and documents on a disk and can hold both files and additional folders
To create a new folder

Open My Documents. 

Under File and Folder Tasks, click Make a new folder. 

A new folder is displayed with the default name, New Folder, selected.

Type a name for the new folder, and then press ENTER. 

Notes

· To open My Documents, double-click the My Documents icon on your desktop. 

You can also create a new folder by right-clicking a blank area in a folder window or on the desktop, pointing to New, and then clicking Folder. 
3.Taskbar

The bar that contains the Start button and appears by default at the bottom of the desktop. You can click the taskbar buttons to switch between programs. You can also hide the taskbar, move it to the sides or top of the desktop, and customize it in other ways.

To add toolbars to the taskbar
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Right-click an empty area on the taskbar. 

Point to Toolbars, and then click the toolbar you want to add. 

*The Address bar lets you quickly go to any Web page you specify. Open the Address bar by double-clicking it. 

*The Links bar provides links to product information on the Web and lets you add Web links by dragging them to the toolbar. Open the toolbar by clicking the double chevron (»). 

*The Desktop toolbar places items from your desktop, such as the Recycle Bin and My Computer, on the taskbar. Open the toolbar by clicking the double chevron (»). 

*The Quick Launch bar displays icons you can click to quickly open programs, show the desktop, or perform other tasks. 

The New toolbar lets you place a shortcut to a folder on the taskba

To arrange all open windows

Right-click an empty area on the taskbar. 

Click Cascade Windows, Tile Windows Horizontally, or Tile Windows Vertically
Task Manager

A utility that provides information about programs and processes running on the computer. Using Task Manager, you can end or run programs and end processes, and display a dynamic overview of your computer's performance.

To lock the taskbar into position

· Right-click the taskbar, and then click Lock the Taskbar. 
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When you lock the taskbar into position, it cannot be moved to a new location on the desktop. 

· To move the taskbar to a new location, click Lock the Taskbar again to clear the check mark, and then drag the taskbar to its new location. 

Locks the taskbar at its current position on the desktop so that it cannot be moved to a new location and also locks the size and position of any toolbar displayed on the taskbar so that it cannot be changed.

Hides the taskbar. To redisplay the taskbar, point to the area of your screen where the taskbar is located. If you want to be sure that your taskbar will be visible whenever you point to it, select the Keep the taskbar on top of other windows check box and also select the Auto-hide the taskbar check box.

Ensures that the taskbar is always visible, even when you run a program in a maximized (full-screen) window.

Displays taskbar buttons for files opened by the same program in the same area of the taskbar. In addition, if the taskbar becomes so crowded with buttons that the width of the buttons shrinks beyond a certain width, then the buttons for the same program are collapsed into a single button. Clicking the button lets you access the document you want. Right-clicking the button lets you close all the documents you want.

Displays the Quick Launch bar on the taskbar. The Quick Launch bar is a customizable toolbar that lets you display the Windows desktop or start a program with a single click. You can add buttons to start your favorite programs.

Displays a digital clock on the taskbar. The clock displays the time as specified by your computer's internal clock. You can point to the clock to display the date, and double-click the clock to adjust the time or date.
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Keeps the taskbar notification area from displaying unused icons.
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Specifies that your default Start menu is the one that gives you quickest access to e-mail and the Internet, your documents, pictures, and music, and the programs you have used recently.

Specifies that your default Start menu has the same look and behavior as earlier versions of Windows.
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Specifies that the icons that represent programs and items on the Start menu are displayed in a larger size.

Specifies that the icons that represent programs and items on the Start menu are displayed in a smaller size. You can increase the number of programs that are displayed in the most recently used programs list by increasing the number in the Programs box.

Specifies the maximum number of programs to display in the most frequently used programs list on the Start menu. You can increase or decrease the number. 

Click to delete the shortcuts displayed in the most frequently used programs list on the Start menu. This does not delete the program from the computer. The next time you run a program, its shortcut is displayed on the Start menu.

Specifies that the Internet item is displayed on the Start menu. Clear this check box to remove the Internet item from the Start menu.

Specifies that the e-mail item is displayed on the Start menu. Clear this check box to remove the e-mail item from the Start menu.
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To arrange your desktop icons
Right-click the desktop. 
Point to Arrange Icons By, and then click one of the commands on the submenu, as explained in the table below. 

	Click
	To

	Name
	Arrange icons in alphabetical order by the icon name.

	Size
	Arrange icons in order of file size. If the icon is a shortcut to a program, the size refers to the size of the shortcut file.

	Type
	Arrange icons in order of type. For example, if you have shortcuts to several PowerPoint presentations on your desktop, these will be arranged next to each other.

	Modified
	Arrange icons in the order that the shortcut was last modified.

	AutoArrange
	Arrange the icons in columns along the left side of your screen.

	Align to Grid
	Snap icons into place as designated by an invisible grid on your screen. The grid keeps the icons aligned with each other.

	Show Desktop Icons
	Hide or show all desktop icons. When this command is checked, desktop icons are displayed on your desktop.


RefreshTo update displayed information with current data.

A shortcut is a quick way to start a frequently used program or open a file or folder without having to go to its installed location. For more information

If you want to create a shortcut to a folder, right-click the folder, and then click Create Shortcut. This creates a shortcut to the folder you selected. To move the shortcut, select it, and then drag it to a new location
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Properties

Display
Desktop
Background, Position, Color

Display
Desktop
Icons (click Customize Desktop to change icons)

Display
Screen Saver
Screen saver

Display
Appearance
Windows and buttons, Color scheme, Font size

Display
Appearance
All features on the Advanced Appearance dialog box 

 A theme is a background plus a set of sounds, icons and other elements to help you personalize your computer with one click

*Save as …

Click to save your current theme with a new name. You will be prompted to type a name for the theme.

The features that are saved as part of your theme include the following options:
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Click to search for background files on other drives or in other folders. You can use files with these file extensions: .bmp, .gif, .jpg, .dib, .png, .htm.
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Lists background display options. Center will display the image in the center of your screen; Tile will repeat the image over your entire screen; Stretch will stretch the image to cover your entire screen. 
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Click to decide what items will appear on your desktop. You can add or remove some Windows program icons from the desktop, and determine which icons are used to represent those programs. You can run the Desktop Cleanup Wizard to remove unused icons on your desktop. You can also customize your desktop to include Web content.
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A screen saver displays moving images that prevent damage to your screen. The screen saver starts automatically if your computer is idle for a specified amount of time. 
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Click to preview the selected screen saver on a full screen. Move your mouse or press any key to end the test.
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Setting option is use to  change settings for the selected screen saver.

open the Power Options Properties dialog box that allows you to adjust the power settings for your monitor.
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Customize the look of windows, menus, fonts, and icons.
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Click to set visual effects for Windows menus, icons, and fonts.
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Click to customize the look of windows, menus, fonts, and icons. This option is only useful if you selected Windows Classic as your theme.
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Displays the current screen resolution settings for the monitor whose video adapter appears in Display. Drag the slider to specify the screen resolution you want. As you increase the number of pixels, you display more information on your screen, but the information decreases in size. 
Color quality 

Displays the current color settings for the monitor attached to the video adapter that appears in Display. To use a different color setting, click the arrow, and then click a setting.

If you need to set your color quality to 256 colors to run a game or other software program that requires it, right-click the program icon or name on your desktop or Start menu, then click Properties. Click the Compatibility tab, and then select the Run in 256 colors check box. Your monitor will revert to your default color setting when you close the program.
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Notepad overview

Notepad is a basic text editor that you can use to create simple documents. The most common use for Notepad is to view or edit text (.txt) files, but many users find Notepad a simple tool for creating Web pages.

Because Notepad supports only very basic formatting, you cannot accidentally save special formatting in documents that need to remain pure text. This is especially useful when creating HTML documents for a Web page because special characters or other formatting may not appear in your published Web page or may even cause errors.You can save your Notepad files as Unicode, ANSI, UTF-8, or big-endian Unicode. These formats provide you greater flexibility when working with documents that use different character sets.

This option is used to create a new file
This option is used to open a file from different location

To save a document in a different location or format
Save as option is use to make duplicate of a saved file.

 In the Page Setup dialog box, do one of the following: 

To change the paper size, click a size in the Size list. To change the paper source, click a tray name or a feeder in the Source list. 
To print the document vertically, click Portrait; to print the document horizontally, click Landscape.                                                                         To change the margins, type a width in any of the Margins boxes.                      To change your printer settings, click Printer.

Header or Footer
In the Header or Footer box, type the letter and character combination from the following table. 

	To
	Type

	Insert the open file's name or (untitled) if the file has no name.
	&f

	Insert the date.
	&d

	Insert the time specified by your computer's clock.
	&t

	Insert page numbers.
	&p

	Insert an ampersand (&).
	&&

	Align the header or footer to the left, center, or right.
	&l, &c, or &r


· You can use more than one combination in the Header or Footer box. Leaving a space or two between each combination will make the header or footer easier to read. 

· To align text to the left, center, or right, you must first enter &l, &c, or &r in the Header or Footer box, followed by any other combinations you want to use. 

· You can also incorporate text with the combinations. For example, Page &p will print out as Page 1, Page 2, and so on. 


Through Print option we can  print the current document.
: - through this option is use to close a file.
Edit Menu

Undo:- You can undo the very last action you took

To cut text so you can move it to another location, select the text, and then on the Edit menu click Cut.                                                                                                    To copy text so you can paste it in another location, select the text, and then on the Edit menu click Copy. 

To paste text you have cut or copied, place the cursor where you want to paste the text, and then on the Edit menu click Paste. 

To delete text, select it, and then on the Edit menu click Delete. 

To find and replace specific characters or words

In Find what, type the characters or words you want to find. 

In Replace with, type the replacement text. 

To replace all instances of the text at once, click Replace All. Or, to replace one instance at a time, click Find Next, and then click Replace.

Date/time: - To insert the time and date in a document
To wrap text to the window size 

Wrapping text enables you to see all the text on the line, but it doesn't affect the way text appears when it is printed.

Font

A graphic design applied to a collection of numbers, symbols, and characters. A font describes a certain typeface, along with other qualities such as size, spacing, and pitch.

On the Format menu, click Font.                                                                             Make your selections in Font, Font style, and Size. 


It shows the current position of text.
Introduction to Microsoft Paint

Microsoft Paint is a simple graphics editing program that is included with Microsoft Windows.  

Although Paint is not very sophisticated, like the Notepad text editor, you may get stuck someplace where you need to do graphics editing and all that is available is Paint.  

In addition, the features of Paint are included in most graphics editing programs in more sophisticated form, so learning Paint is a good introduction to other graphics editing programs. 
General Information

Microsoft Paint is the default application for processing Windows bitmap files. Bitmaps are one form of graphics commonly used on computers (most background images you see are bitmaps). They are generally too large for use on the internet, however. 
The default file extension of a bitmap file is .bmp. If you see a file that ends with that, it is a bitmap image.
  Drawing area 

When started, Paint displays a default drawing area which is called the canvas. 

Remember that, like in all the other Microsoft products, if an action is done that is not desired, select "Edit", "Undo" (shortcut Ctrl-Z) to undo the action. 
Explanation of tools on the toolbar:

Selecting and Viewing parts of the picture
[image: image1.jpg]


Free-form Select button:-Used to select areas of the image in any shape.  
Magnifying tool:Zooms in to the picture to see more detail 

Select the area you want to erase, to select a rectangular area, or click

Click the area containing the color you want to copy

· Click to [image: image2.png]


apply an opaque background. 

· Click [image: image3.png]


to apply a transparent background. 

· [image: image4.png]


 Polygon the border width of the polygon is the same as the thickness selected for the line tools. To change the border thickness, click the line or curve tool in the toolbox, and then click the thickness you want in the box below the toolbox
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Text:- To create a text frame, drag the pointer diagonally to the size you want
· [image: image6.jpg]



· [image: image7.jpg]


To draw a free-form line

· [image: image8.jpg]


To draw a curve

· [image: image9.jpg]


 To draw an ellipse or circle

· [image: image10.jpg]


 To draw a rectangle or square







          [image: image11.jpg][=]



In the toolbox, click the square to create a square-cornered shape, or click the rounded edge square to      create a round-cornered shape. 

                                                         
To set the foreground and background colors

1. To set the foreground color click a color in the color box. 

2. To set the background color right-click a color in the color box. 

3. The colors selected appear at the left in the color box. The top color is the foreground color. The bottom color is the background color. 
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To pick a color (from an image that has colors already)



                       [image: image13.jpg]


To fill an area or object with color

 



                            [image: image14.jpg]


To paint with a brush
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To erase a small area

· Airbrush:- To spray, drag the mouse pointer over the image

· Line:-Drag the pointer to draw the line

The File Menu
The File Menu is where you’ll find commands that affect the file you’re working on in its most basic aspects. This is where you’d go to create a new file, open a file, save a file, or print a file. In fact, most basic phrases that end with "file" will be found… guess where? In the File Menu. 
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 New: -
Creates a new, blank (white) image file.

Open: -
Initiates the Open dialog box to open (view) an existing image file.  Note that in Paint only    

                              one image file can be open at one time.  If you try to open a second file, the first file will be   

                              closed automatically.

Save: -
Saves changes to the current file.

Save As: -
Saves changes to the current file, and allows you to pick a new or different file name for the
file
Print Preview: -
Displays the image on screen as it will appear when it is printed out on paper. This lets you 
                              get a sense among other things, of how big the image will be when you print it to the page.

Page Setup: -
Displays options for setting up how Paint will print your file. Note that these settings will 
                               not be saved with the image if you use the Save command later.

Print: -
Displays the Print dialog box, where you can Print out the current image file.

Send: -
(Not covered in this class.)

1, 2, 3: -
Opens the 1st, 2nd, or 3rd previous files opened with Paint.

Exit: -
Shuts down Paint.

The Edit Menu
The Edit Menu is where you’ll find most of your commands that are useful for working within your file to make changes of one kind or another. As far as useful commands go, the Edit Menu is another "heavy hitter." [image: image17.png]Edt View Image Colors
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Undo: 
This is probably the most important single command to remember. Undo will remove the last change you made to the file. For instance, if the last thing you did was to draw a line with the Line Tool, selecting Edit  Undo would remove the line. This is great when you screw up and want to call a "do-over." You’ll use Undo over and over again, 
Repeat: 
Repeat is like the reverse of Undo. It will re-apply the last change that you made to the file you’re working on. It doesn’t seem to be a useable option most of the time, however. You’ll find that it’s grayed out most of the time, and not a particularly useful feature.
Cut, Copy, Paste
Cut, along with Copy, and Paste are some of the most useful commands in Paint. These are used in conjunction with the Selection tools. First, use either the rectangular or freeform Selection tool to select a portion of the image. The Cut command will remove the selection from the image, just as though you cut it out with a pair of scissors or an x-acto knife. The Cut portion of the image is not gone, however. It is stored in the computer’s copy buffer, where it can be retained temporarily. Copy works much like Cut, in that it places the selected portion of the image into the copy buffer, but it does not remove the selection from where it originally appears in the image. Paste is how you get stuff out of the copy buffer and back onto the image; it "pastes" the contents of the copy buffer back into the image, where you can move it around before deselecting it.  

Cut and Paste are good for moving bits of an image around.  

Copy and Paste are good for duplicating portions of an image to create a motif or pattern or collage-like effect.
Clear Selection:
Clear Selection is also used in conjunction with the Selection tools. When you use Clear Selection, whatever is in the selection will be deleted. It’s a little trickier than simply using the eraser and zoom, and less precise, but it’s quicker.
Select All: 

This command automatically selects the entire image. You can then use Cut, Copy, Paste, or Clear Selection.
Copy To, Paste From: 

 These commands work with an outside file instead of the copy buffer. The copy buffer is like an invisible file that is associated with the Paint Program itself. This is useful, but limited, because only one thing can be in the copy buffer at a time, and when Paint is shut down the contents of the copy buffer may be lost. Or, if you are working with two programs, such as Paint and Microsoft Word, using the Copy command in one program may overwrite the contents of the copy buffer in the other program. When you’re working with copying and pasting a lot, you may find that you wish that you could keep more than one object in the copy buffer at a time.  

This is what Copy To/Paste From are for. You must have something selected in order to Copy To. Whatever you’ve selected gets saved as a separate file. Paste To works in a complimentary fashion, by pasting the contents of some separate file into your active Paint file.  

These are useful features, but they require the added step of using a dialog box to save or open a file, and are thus slower than the regular Copy/Paste commands. Only use these if you know you’ll be needing a selection frequently as you do your work
The Image Menu
Next to the File and Edit menus, the Image Menu is probably the menu where you’ll find the most useful features. You won’t use these as often as the File and Edit menu commands, but you can think of the commands in the Image Menu as being your Paint "power tools". You can use these tools to alter your image or selection in a number of interesting and useful ways. 
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Flip/Rotate

Flip will allow you to "flip" the selection over like a pancake. You can choose between horizontal or vertical for the direction of your flip. This is good if you need to create a "mirror image" of a selection. 

Rotate will rotate the selection. The Rotate command in Paint is not extremely flexible, so you’re limited to right-angle rotations (that is, 90, 180, and 270 degrees of rotation.)
Stretch/Skew

Stretch will let you change the proportions of the selection, making them narrower, wider, shorter, or taller. The ratio of the selection’s height and width will change, and will result in some distortion of the image. 

Skew is similar to stretch, but it affects opposing edges oppositely. For example, a horizontal skew might shift the top of the image to the right while the bottom of the image stretches to the left. This results in an effect that can be used in making an illusion of 3-d Perspective.
Invert Colors

You’ll get an effect similar to a photographic negative.
Attributes

Here is where you can change the basic image attributes such as height and width (which can be measured in pixels, inches, or centimeters), colors (switch between b&w and color), and transparency (may not be available for all file types.)
Clear Image

Self-explanatory; this wipes out the image, leaving you with a blank file with the same image dimensions.
Draw Opaque

Works with the selection. If unchecked, any background color (the default is white) in your selection will be treated as transparent. This transparency can be observed by moving the selection around – as the transparent portions of the image move over other areas of the image, you should be able to see those areas peeking through the selection. If unchecked, the background color will remain opaque when the selection is moved about in the image.

The Colors Menu
The colors menu only has one command in it, Edit Colors. 
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The interface for this command is a bit complicated compared to what we’ve looked at thus far. 
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This is the basic Edit Colors window. This will open up on top of the regular Paint window when you select Edit Colors from the Colors Menu. 

From here, you can customize your color palette. The Color Palette is the portion of the Paint window from which you can select which color you want to use to paint or draw with. Since there are only a relatively small number of colors available through the basic Color Palette, you’ll probably want to pick custom colors at some point if you’re doing a lot of actual drawing with the drawing Tools. 

To do this, click on "Define Custom Colors". This button will cause the Edit Colors window to expand, and you’ll be able to select new colors from the Color Picker. 
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As you can see here, the color picker allows you to pick from a wide variety of shades in the RGB color gamut. RGB color is the color scheme used by mixing the primary colors of light, Red, Green, and Blue, and is the basis for all color computer graphics. 

The View Menu 

The View Menu isn’t particularly useful. You can toggle whether the Tool Box, Color Box, or Status Bar will be displayed here. You can also set the Zoom here, but since you can do that quicker with the Zoom tool, it’s hardly useful. View Bitmap will display the image at full size all by itself with none of the usual Paint window objects to get in the way. 

Tip:  If you're looking around in the main Paint window for the Tool Box, Color Box, or Status Bar, and you can't see it, that means they're hidden.  To show them, go into the View Menu and make sure that the check mark appears next to each in the menu. 
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